Q: 04 cvpi started running lean after changing spark plugs

asked by on April 16, 2017

My boyfriend recently changed my spark plugs, and now my car is running like crap. I bought an obd 2 scanner and it's showing codes saying that my car is running lean. What is going on?
My car has an automatic transmission.

Check Engine Light is on Inspection $79.99 - $99.99 Get a Quote

Check to make sure the plugs are tight but do NOT overtighten them. Use a calibrated inch pound torque wrench only; if oil is on the spark plug threads, request assistance from a mechanic in tightening the plugs because the oil throws off the torque readings and that can cause overtightening of the plugs. The lean operating condition might just be a coincidence insofar as the nearness of occurrence to the plug replacement. The specific code(s) you have downloaded would be used by the mechanic to narrow the diagnostic but typical causes of lean operation are a faulty fuel pressure regulator, a weak fuel pump, a clogged fuel filter, a faulty powertrain control module (rare), a vacuum leak, faulty injector(s), faulty oxygen sensor(s), and/or a faulty mass air flow sensor. If you want the necessary diagnostic steps performed by a certified Mechanic, dispatched by YourMechanic right to your location, please request a check engine light diagnostic and the responding certified mechanic will get this taken care of for you.

The statements expressed above are only for informational purposes and should be independently verified. Please see our terms of service for more details

Get an instant quote for your car

Our certified mechanics come to you ・Backed by 12-month, 12,000-mile guarantee・Fair and transparent pricing


Experienced Mechanic?

Earn up to $70/hr

What others are asking

I have an 07 Tahoe. I disconnected to negative terminal. When I re-connected it I had a no crank no start and several electronics did not work ie: door locks, tire pressure system, wipers, interior lights. Prior to disconnecting the neg terminal it ran fine. I installed a new pre-programmed BCM. Still no start, no crank. All of the fuses and relays have been checked. New Battery installed.

P0505 code Idle Air Control for bmw 540i

The TPS can have between 5 and 10 different codes and all will be caused by different failures of the TPS, Throttle body, wiring or computer issues and you will need to supply the code you get to help you...

How to safely lift my vehicle

Hello. The jacking points on your vehicle should be marked by a triangle on the side of the pinch weld pointing down. You place the jack right underneath the pinch weld to lift up the vehicle. The lifting points should...

I drive my suzuki sx4 sport and as im driving i hear a knocking noise....when i break the noise stops......is it my bearing? 2007 Suzuki SX4

Hello - your symptoms suggest a worn front wheel bearing. The "steering is a bit loose" symptom reinforces this diagnosis. If the noise ceases when turn left, it is likely the left wheel bearing. It would be the right wheel...

check engine light stays on, replaced the mass air flow sensor

Hello, thank you for writing in. The vehicle will need to be scanned for diagnostic troubleshooting codes. The computer will set a code when issues have been detected. These codes are a way of helping you or the technician to...

Car does not run on forward only reverse

This may be a sign of low transmission fluid or a faulty transmission control solenoid. As you know, automatic transmissions use pressurized hydraulic fluid to change gears. Every time a gear change is required, the car's computer activates a transmission...

My car runs hot, past the middle of the gauge, when stopped or sitting at idle.

This is most likely related to a faulty or sticking thermostat or a bad coolant fan relay switch. As you know, the thermostat regulates the coolant flow in and out of the engine and keeps the circulation of coolant going...

Speedometer and odometer off when starting the car

Hey there. Although we need a bit more information from you to accurately pinpoint the source of your issue, it sounds like this could be due to a damaged or faulty transmission speed sensor. Sometimes the speed sensor, which monitors...

I have no spark, no ignition, no current is going to the ignition coil. Could this be a Auto Shut-Down Relay?

The automatic shutdown (ASD) relay powers the coil and is turned on and off by the engine control module ECM. If you scan the engine and get a code 40, then you may have a bad ASD relay, but there...

Related articles

Understanding Ford Intelligent Oil-Life Monitor (IOLM) System and Lights
Car symbols, or dashboard lights, are a car service reminder. The Ford Intelligent Oil-Life Monitor indicates when and what service your car needs.
The Best Used Cars to Buy If You're an Uber or Lyft Driver
Are Are you thinking of becoming a driver for Uber or Lyft? That could be an exciting career change – you’ll get to meet a lot of interesting people, and if you love to drive, what better way to spend...
A Buyer’s Guide to the 2007 Ford Crown Victoria
This This enduring Ford classic enjoyed a nearly two-decade run before being discontinued from the retail market with the 2007 model-year being the last. Ever-popular with law enforcement (for whom models continued in production through 2011), and senior citizens, the...