Q: New battery and alternator but there is still no power in my 204 Xterra onve I turn it off.

asked by on

Instilled a new battery after my 04 3.3L Xterra would not start in the morning. The old battery was to small for it and did not look in good shape.
Drove it for a week then went to start it one day put the key in the ignition , dash lights lit up car was dinging like normal, turn the key and the car dies instantly. It was like I hit the off swich to the power. Replaced the alternator, the ground wire from the battery, and had the new battery checked (the battery was good but they still gave me another new one). Installed new one and it started right up. Drove it for a day then went in to a store came out and turned the key and again died instantly! Put my multimeter on the battery and it reads 12.68v. Checked the fuses by eye under the hood, but it well start if it's jumped. Im completely at a lose on what to do next? Any help would be awesome!

My car has 170000 miles.
My car has an automatic transmission.

Hi there. It sounds like you either have a defective alternator or there is another issue within the circuit for the charging system. I usually start by checking the output of the alternator. If it is not putting out the right voltage or amperage then it needs to be replaced. I would then check to see if the alternator is getting the correct signal to turn on. These would tell me if the output if correct. If the alternator is putting out the right voltage then the positive battery cable may have failed and may have high internal resistance. If you need to have this checked out, consider YourMechanic, as a certified mechanic can come to you to [diagnose why the vehicle is losing electrical power] https://www.yourmechanic.com/services/electric-problems-inspection

Was this answer helpful?
The statements expressed above are only for informational purposes and should be independently verified. Please see our terms of service for more details
  1. Home
  2. Questions
  3. New battery and alternator but there is still no power in my 204 Xterra onve I turn it off.

Get an instant quote for your car

Our certified mechanics come to you ・Backed by 12-month, 12,000-mile guarantee・Fair and transparent pricing

Get a quote

What others are asking

Q: Speedometer not working in a 2004 Chrysler PT Cruiser

There may be a wiring issue in the speedometer circuit, or the gauge in the instrument cluster may be bad. I would ask for help from one of the mechanics at YourMechanic to help diagnose and repair your speedometer concern....

Q: Why do I need to charge my car's battery ever week or two but I cannot find an obvious problem withe the electronic system.

If you are starting the car and only operating it for a very short period, such short duration operation does not give the car's charging system sufficient time to re-charge the battery. Consequently, repeated short trips, especially in cold weather...

Q: Replaced the IAC on my 04 Xterra now idle surges

Sounds like you have taken a lot of the right steps, but lets go back to the beginning. A P0505 code doesn't necessarily mean the IAC is bad. Specifically it says that there is a malfunction in the idle control...

Related articles

How Do Power Car Windows Increase Passenger Safety?
Power windows are responsible for approximately 2,000 emergency room visits every year. When a power window closes, it exerts enough force to bruise or break bones, crush fingers, or restrict an airway. Though...
How to Avoid Back Pain in a Car
If you have back problems, sitting in a car for an extended period of time can be excruciating. Even without back problems, you could experience discomfort and soreness from...
P2428 OBD-II Trouble Code: Exhaust Gas Temperature Too High Bank 1
P2428 code definition A P2428 trouble code signifies that the PCM has detected a problem in the exhaust gas temperature sensor circuit in bank 1, which subsequently contains the number one...