Q: automatic transmission works fine in reverse, 1st, and 2nd, but revs the engine in 3rd 4th 5th only goes 30mph

asked by on May 11, 2017

Check engine light is on, automatic transmission works fine in reverse, 1st, and 2nd gear, but when it goes to 3rd, 4th, and 5th it doesn't accelerate the car, it just revs the engine, the car only goes around 30mph.

My car has 215000 miles.
My car has an automatic transmission.

You could have a defective vehicle speed sensor, transmission shift solenoids, transmission control module, valve body in transmission, throttle position sensor and/or the interconnecting wiring, fuses, and terminals (involving the electrical components) could have a defect. Another possibility is an internal hydraulic leak in the circuit that takes over once 3rd gear comes into play. The Factory Service Manual sets out a basic decision tree to narrow the diagnostic. You can simply apply that tree or to make quicker work of this, YourMechanic can dispatch a certified mechanic to perform the diagnostic. Some transmission faults, particularly electrical in nature, but also including almost anything to do with the internal valve body, can be repaired without removing the transmission. If, though, an internal piston has failed or a hydraulic circuit is leaking, usually it most efficient to just simply rebuild the whole transmission as it has to be removed from the car anyway to perform the latter category of repairs (i.e., piston, seal failure, etc.). There’s always a chance of a relatively simple cause, so I do encourage you to request a transmission shift diagnostic to see if this can be resolved on the car. If you have further questions or concerns, do not hesitate to re-contact YourMechanic as we are always here to help you.

Was this answer helpful?
The statements expressed above are only for informational purposes and should be independently verified. Please see our terms of service for more details

Get an instant quote for your car

Our certified mechanics come to you ・Backed by 12-month, 12,000-mile guarantee・Fair and transparent pricing

Get a quote

What others are asking

Speedometer stops on 40 mph until driving for 20 minutes and then regains correct speed on the speedometer with no other noticeable issues.

Hi there. The issue with your speedometer not working properly is the transmission output shaft speed sensor has a faulty pickup or broken wire inside it. The speed sensor has a magnet that reads between teeth on a gear within...

I have to park my car with hand break. Park doesn't work !

You will need to have the shift cable ends inspected for worn out bushings. The shifter is not putting the transmission all the way back into park. You may have to replace the shift cable or if the connectors are...

Car vibrates in idle and trouble accelerating after stopped

Hi there, thanks for writing in about your 2003 Subaru Baja. There are dozens of potential causes for the symptoms you are having. It could be an engine performance problem, such as a bad sensor. It could also be a...

Related articles

How an Automatic Transmission Works
An An automatic transmission allows a vehicle engine to operate within a narrow speed range, just like a manual transmission does. As the engine achieves higher degrees of torque (torque is the rotational power of the engine), the gears in...
Symptoms of a Bad or Failing Neutral Safety Switch
Common signs of a faulty neutral safety switch include the engine not cranking in park or neutral, not cranking at all, or cranking in any gear.
How to Decide Between Manual and Automatic Transmissions
There There are a lot of decisions that have to be made when buying a new car. Everything from choosing a make, model, and trim level to deciding if upgrading the stereo is worth the extra money. One of the...