Skip the auto shop - Our mechanics make house calls

Q: Alternator not charging battery a600

asked by on

I have a 01 mercedes s600 and when purchased the car the alternator was not charging the battery at idle but some at higher rpms. Purchased a rebuilt one from autozone and had it installed and still did not work. Just purchased a oem used alternator with 15k miles on it hoping this should fix the problem. Any advice?

My car has 103000 miles.
My car has an automatic transmission.

Hello, It sounds like you may have a voltage regulation problem which may be preventing the alternator from doing it’s job properly. The voltage regulator is a unit that regulates the charging of the battery by the alternator and maintaining a certain amperage while the engine runs. When the alternator is not working properly, this may result in the battery quickly losing charge and the car losing all power as you have described. You may also notice a whining sound as a result of the bearings inside the alternator begin to fail. I would recommend having an expert from YourMechanic come to your location to diagnose and inspect your charging system.

Was this answer helpful?

Need advice from certified mechanic? Get help now!

Over 1000 mechanics are ready to answer your question.
The statements expressed above are only for informational purposes and should be independently verified. Please see our terms of service for more details

Get an instant quote for your car

Our certified mechanics come to you ・Backed by 12-month, 12,000-mile guarantee・Fair and transparent pricing

Get a quote

What others are asking

Q: Where is the crankshaft sensor on merceds c250

Look for a three terminal (three wire) wiring harness plug either adjacent to the harmonic balancer in the front of the engine or, in some models, towards the rear of engine on the driver’s side, near the firewall. If you...

Q: Code p1391

Hi there: Although the O2 sensors can cause intermittent starting problems, one of the most overlooked components that can trigger this OBD-II error codes and cause the issues you're describing is a camshaft position sensor, or the electrical harness attached...

Q: Power steering upon start up shows gurgling in reservoir after hot starts foaming and making noise 2007 Mercedes S600

Hi - your symptoms suggest the power steering system has either run low on fluid, sucking air into the system, or the system filter is clogged, creating air in the system through cavitation of the pump (vacuum bubbles). I would...

Related articles

How Long Does a Distributor O Ring Last?
The distributor is part of the ignition system in your vehicle and its purpose is to route high voltage from the ignition coil to the spark plug. The spark plug then...
How Long Does a Heater Control Valve Last?
Keeping the right amount of coolant in a car is essential in keeping the engine at the right temperature. Failing to have the right amount of coolant or even bad elements...
How to Avoid Back Pain in a Car
If you have back problems, sitting in a car for an extended period of time can be excruciating. Even without back problems, you could experience discomfort and soreness from...