Q: I have a 01 Aurora that hasn't had heat for a year but it always ran at perfect temp until now, although it's not red lining.

asked by on

Bought the car year n half ago had heat first cpl days then went out, but car ran at perfect temp until now although it's not red lining but is running well hotter than should be. So my question is do you think it's thermostat issues?

My car has 168000 miles.
My car has an automatic transmission.

There could be an issue with the thermostat in the car and that is the first place you will need to check when trying to repair this problem. Also, check for signs of a failing or worn water pump that could possibly cause this issue. Sometimes, dirty antifreeze can cause clogs in the coolant system, causing no heat and overheating conditions.

I suggest that you start by getting the thermostat changed and flushing the antifreeze. If you need assistance, get a certified technician, such as one from YourMechanic, to replace the thermostat and flush the cooling system for you.

Was this answer helpful?
The statements expressed above are only for informational purposes and should be independently verified. Please see our terms of service for more details
  1. Home
  2. Questions
  3. I have a 01 Aurora that hasn't had heat for a year but it always ran at perfect temp until now, although it's not red lining.

Get an instant quote for your car

Our certified mechanics come to you ・Backed by 12-month, 12,000-mile guarantee・Fair and transparent pricing

Get a quote

What others are asking

Q: Why does my heater only blow warm and not hot on my 2000 Dodge Stratus

Hello. It does take some time for the coolant to get hot enough to blow hot inside of the vehicle. I usually start by checking the coolant level. Low coolant will cause this. If the coolant level is fine then...

Q: Q: Heat and air

Hello. If the temperature is not changing at all then most of the time this is caused by an issue with the blend door motor. If this has failed then the temperature door will be stuck in one position. I...

Q: front display module not working,radio buttons not working. 2010 escape v6

Hello, thanks for writing in about your Ford Expedition. You should have the radio display removed and then install the fuses again to check if they will blow again. If the fuses don't blow again then the radio is shorted....

Related articles

P0052 OBD-II Trouble Code: HO2S Heater Control Circuit High (Bank 2 Sensor 1)
P0052 code definition HO2S Heater Control Circuit High (Bank 2 Sensor 1) What the...
Rules of the Road For Iowa Drivers
Driving on the roads requires knowledge of the rules, many of which are based on common sense and courtesy. However, even though you know the rules in...
What are the Car Pool Rules in Hawaii?
Hawaii is widely regarded as a land of vacation and relaxation, and as such, its scenic roads and routes are far better known than the state’s freeways. But, as with all...